[Proposal] Use XClass, XObject, XProperty to name the XWiki concepts
Hi, Sometimes it's hard to make the distinction (in a conversation) between XWiki classes/objects/properties and the java terms. Thus, we should call them XClass, XObject and XProperty. Of course, class/object/property are still valid, when everybody knows what we're talking about. Sergiu -- http://purl.org/net/sergiu
+1 On 4/10/07, Sergiu Dumitriu <sergiu.dumitriu@gmail.com> wrote:
Hi,
Sometimes it's hard to make the distinction (in a conversation) between XWiki classes/objects/properties and the java terms. Thus, we should call them XClass, XObject and XProperty. Of course, class/object/property are still valid, when everybody knows what we're talking about.
Sergiu -- http://purl.org/net/sergiu
-- You receive this message as a subscriber of the xwiki-dev@objectweb.org mailing list. To unsubscribe: mailto:xwiki-dev-unsubscribe@objectweb.org For general help: mailto:sympa@objectweb.org?subject=help ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
On Apr 10, 2007, at 8:41 PM, Sergiu Dumitriu wrote:
Hi,
Sometimes it's hard to make the distinction (in a conversation) between XWiki classes/objects/properties and the java terms. Thus, we should call them XClass, XObject and XProperty. Of course, class/ object/property are still valid, when everybody knows what we're talking about.
I'm +1 too but provided you document them on xwiki.org (in the developer area, on a glossary page) ;-) Thanks -Vincent
If we vote for this, definitely. We do need a better documentation for them. On 4/10/07, Vincent Massol <vincent@massol.net> wrote:
On Apr 10, 2007, at 8:41 PM, Sergiu Dumitriu wrote:
Hi,
Sometimes it's hard to make the distinction (in a conversation) between XWiki classes/objects/properties and the java terms. Thus, we should call them XClass, XObject and XProperty. Of course, class/ object/property are still valid, when everybody knows what we're talking about.
I'm +1 too but provided you document them on xwiki.org (in the developer area, on a glossary page) ;-)
Thanks -Vincent
Sergiu -- http://purl.org/net/sergiu
+1 2007/4/10, Sergiu Dumitriu <sergiu.dumitriu@gmail.com>:
Hi,
Sometimes it's hard to make the distinction (in a conversation) between XWiki classes/objects/properties and the java terms. Thus, we should call them XClass, XObject and XProperty. Of course, class/object/property are still valid, when everybody knows what we're talking about.
Sergiu -- http://purl.org/net/sergiu
-- You receive this message as a subscriber of the xwiki-dev@objectweb.orgmailing list. To unsubscribe: mailto:xwiki-dev-unsubscribe@objectweb.org For general help: mailto:sympa@objectweb.org?subject=help ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
participants (4)
-
Catalin Hritcu -
Jean-Vincent Drean -
Sergiu Dumitriu -
Vincent Massol