[xwiki-devs] Rule for configuration property naming in documentation
Hi guys, A long time ago I sent a vote for naming configuration property http://markmail.org/thread/xzz2gqmexkgargbz And this is what has been mostly used in xwiki.properties… However some developers have not followed the existing rules. For example: # solr.embedded.home=/var/local/xwiki/solr # solr.remote.url=http://localhost:8983/solr # solr.indexer.batch.size=50 # solr.indexer.batch.maxLength=10000 # solr.indexer.queue.capacity=100000 This is a pity since it’s hard to change a property. I have now taken the time to document it in our dev practices at http://dev.xwiki.org/xwiki/bin/view/Community/DevelopmentPractices#HConfigur... If some dev has an issue with this please raise it here. If not, please make sure to follow it from now on. Thanks -Vincent
On Thu, Jan 9, 2014 at 3:42 PM, vincent@massol.net <vincent@massol.net> wrote:
Hi guys,
A long time ago I sent a vote for naming configuration property http://markmail.org/thread/xzz2gqmexkgargbz
And this is what has been mostly used in xwiki.properties…
However some developers have not followed the existing rules. For example:
# solr.embedded.home=/var/local/xwiki/solr # solr.remote.url=http://localhost:8983/solr
I don't fully agree that the rule has not been followed in this case, from solr architecture point of view "embedded" and "remote" are two different modules, these are the hints of two different component for the same role. Even if it's not a separated module, mostly because it was too small, it's still two different sub parts of solr that need to be clearly separated in the configuration to be more readable because they have very different properties.
# solr.indexer.batch.size=50 # solr.indexer.batch.maxLength=10000 # solr.indexer.queue.capacity=100000
This is a pity since it’s hard to change a property.
I have now taken the time to document it in our dev practices at http://dev.xwiki.org/xwiki/bin/view/Community/DevelopmentPractices#HConfigur...
If some dev has an issue with this please raise it here.
If not, please make sure to follow it from now on.
Thanks -Vincent
_______________________________________________ devs mailing list devs@xwiki.org http://lists.xwiki.org/mailman/listinfo/devs
-- Thomas Mortagne
On 13 Jan 2014 at 09:29:54, Thomas Mortagne (thomas.mortagne@xwiki.com(mailto://thomas.mortagne@xwiki.com)) wrote:
On Thu, Jan 9, 2014 at 3:42 PM, vincent@massol.net wrote:
Hi guys,
A long time ago I sent a vote for naming configuration property http://markmail.org/thread/xzz2gqmexkgargbz
And this is what has been mostly used in xwiki.properties…
However some developers have not followed the existing rules. For example:
# solr.embedded.home=/var/local/xwiki/solr # solr.remote.url=http://localhost:8983/solr
I don't fully agree that the rule has not been followed in this case, from solr architecture point of view "embedded" and "remote" are two different modules, these are the hints of two different component for the same role. Even if it's not a separated module, mostly because it was too small, it's still two different sub parts of solr that need to be clearly separated in the configuration to be more readable because they have very different properties.
Maybe but that doesn’t change anything to the rest of the properties below (like solr.indexer.batch.size) nor to other properties located in this file that are also not following this naming rule. These were just a small subset of the occurrences that can be found. Thanks -Vincent
# solr.indexer.batch.size=50 # solr.indexer.batch.maxLength=10000 # solr.indexer.queue.capacity=100000
This is a pity since it’s hard to change a property.
I have now taken the time to document it in our dev practices at http://dev.xwiki.org/xwiki/bin/view/Community/DevelopmentPractices#HConfigur...
If some dev has an issue with this please raise it here.
If not, please make sure to follow it from now on.
Thanks -Vincent
participants (2)
-
Thomas Mortagne -
vincent@massol.net