Branch: refs/heads/develocity-mcp Home: https://github.com/xwiki/xwiki-dev-llm Commit: 777f8c82bedb7c99b00e424aecfbe397f349ce39 https://github.com/xwiki/xwiki-dev-llm/commit/777f8c82bedb7c99b00e424aecfbe3... Author: Vincent Massol <vincent@massol.net> Date: 2026-08-31 (Mon, 31 Aug 2026) Changed paths: M .claude-plugin/marketplace.json M README.md M kimi.plugin.json M opencode.jsonc M xwiki/.claude-plugin/plugin.json M xwiki/.mcp.json M xwiki/okf/servers/index.md M xwiki/okf/servers/jenkins.md Log Message: ----------- [Misc] Add a Develocity MCP server * Add the `develocity` MCP server to all three host manifests, pointing at ge.xwiki.org, XWiki's Develocity instance: build failures with stack traces, test outcomes and flaky-test history, build timings, cache effectiveness and build-to-build diffs. * Configure it as a remote streamable-HTTP server on every host, so nothing runs locally: Claude Code and opencode interpolate the access key into an Authorization header, while Kimi Code uses its bearerTokenEnvVar field, which reads the token from the environment rather than the config. * Read the key from DEVELOCITY_MCP_ACCESS_KEY rather than DEVELOCITY_ACCESS_KEY. The two hold the same Develocity access key but cannot hold the same value: the Maven and Gradle extensions require DEVELOCITY_ACCESS_KEY to be host-scoped (`ge.xwiki.org=<key>`, so a key cannot be sent to a server it was not issued for), whereas a Bearer header needs the bare key. A separate name lets a developer authenticate both their local build and the MCP server. * Leave the key optional: unset, Claude Code and Kimi Code skip the server. Develocity validates the key on every request including tool listing, so a keyless server would error each session instead of degrading to read-only, as the discourse one does. * Record the server in okf/servers/index.md, whose map still described ge.xwiki.org as having no MCP, and point okf/servers/jenkins.md at it for why a build failed, Jenkins remaining the authority on whether it did. * Bump the plugin version to 1.4.0 (minor: a capability change). Co-Authored-By: Claude Opus 5 (1M context) <noreply@anthropic.com> To unsubscribe from these emails, change your notification settings at https://github.com/xwiki/xwiki-dev-llm/settings/notifications