Branch: refs/heads/CRISTAL-201 Home: https://github.com/xwiki-contrib/cristal Commit: befe17462547e231e942ed2d2d85b5fb1e0a7411 https://github.com/xwiki-contrib/cristal/commit/befe17462547e231e942ed2d2d85... Author: Pierre Jeanjean <pierre.jeanjean@xwiki.com> Date: 2024-09-05 (Thu, 05 Sep 2024) Changed paths: M core/navigation-tree/navigation-tree-api/src/index.ts M core/navigation-tree/navigation-tree-default/src/components/componentsInit.ts M core/navigation-tree/navigation-tree-filesystem/src/components/componentsInit.ts M core/navigation-tree/navigation-tree-github/src/components/componentsInit.ts M core/navigation-tree/navigation-tree-nextcloud/src/components/componentsInit.ts M core/navigation-tree/navigation-tree-xwiki/src/components/componentsInit.ts M ds/shoelace/src/vue/x-navigation-tree.vue M ds/vuetify/src/vue/x-navigation-tree.vue M skin/src/vue/c-sidebar.vue Log Message: ----------- CRISTAL-201: Introduce a Navigation tree * Rename `NavigationTreeResolver` to `NavigationTreeSource` * Rename `getNavigationTree` to `getChildNodes` * Add missing escaping * Other minor improvements To unsubscribe from these emails, change your notification settings at https://github.com/xwiki-contrib/cristal/settings/notifications