On Fri, Nov 2, 2012 at 7:13 AM, Thomas Mortagne <thomas.mortagne@xwiki.com>wrote:
Hi devs,
Quick vote for the macro name: * {{l10n}} * {{locallization}}
localization is a bit too long for a macro so I would go for "l10n".
We can also decide to maintain both aliases.
Localization is a process, it involves the whole product, so it's not appropriate to use it on just one string. I think that translation or translate is the right term. And I think that a noun is better, for consistency. We're describing what's inside the macro (or what comes out of it), not what the macro does: messageSender, column, chart, livetable... -1 for abbreviations, even though this one will be used more often than the other macros, it's always a good idea to stay away from very short names. We wouldn't use abbreviations in our Java API method names, would we? So, +1 for {{translation}}. -- Sergiu Dumitriu http://purl.org/net/sergiu/